Browser Security for Websites

Browser Security for Websites

Older Internet browsers such as Internet Explorer 5.5 and earlier versions did not have 128 bit encryption.  This meant that you were blocked from accessing secure sites such as NFN Webmail and other sites using https.  Add-ons were offered by Microsoft for the older browser, but links to these are no longer present as Microsoft has discontinued support for older software.

If you are using an older computer system with older browser versions and cannot access secure sites, you will need to either upgrade your browser or upgrade your operating system to include an updated browser with at least 128 bit encryption.

Leave a Reply

Your email address will not be published. Required fields are marked *